Terminal için kabuğu değiştirmemelisiniz hatası ve çözümü

Merhaba, terminalimi daha belirgin hale getirirken garip bir hata ile karşılaştım. Türkçe içeriği yok ingilizce olarakta aradığım sorun ile bir türlü örtüşemedim. Biraz ordan dene biraz burdan dene derken powerpuff girls :D  Sorunu çözüm. Belki bu hata ile karşılaşan olur ise bu kaynaktan yararlansın.

  1. Öncelikle daha önce Oh My Zsh  vb terminal eklentilerini kurduysanız genelde bu sorun bundan kaynaklanıyor. Ben zsh yerine farklı bir plugin kullanmak istediğimden ötürü bu hata ile karşılaşıyordum.
    chsh - s /usr/bla/blashell   shelinizi değiştirmeye çalıştığınızda  bu hatayı verecektir.
  2.  sudo subl /etc/passwd   subl yerine nano gedit vs de kullanabilirsiniz burada /bin/zsh veya değiştirmek istediğiniz pluginin kısa adı ne ise onu yazıyorsunuz. Ben fish shell kullanacağım için fish yazdım. Aşağıda ki resimde gördüğünüz 1 ve 40 satırdaki kodları değiştirdim. Sizde farklı yerde olabilir.

  3. İyi çalışmalar :)

0 yorum:

Yorum Gönder

 

Reklam engelleyici uygulamalarını, blog sitemiz için kapatarak çalıştırın lütfen.

Bunu yapmak için; Reklam Engelleyici Bildirim Listesi sayfasına giderek yapabilirsiniz.

Teşekkürler!

×